Monitor Mikrotik dengan Netwatch dan Bot Telegram

Monitoring Netwatch


    Sebelumnya Amarilo pernah membahas tentang Telegram pasti tau kelebihannya Telegram yang menurut Amarilo menonjol yaitu adanya fitur Bot yang bisa kita gunakan sesuai kebutuhan kita, tapi sepengetahuan Amarilo setiap satu akun Telegram hanya bisa membuat satu Bot maka dari itu kita manfaatkan sebaik mungkin.

    Beberapa dari pembaca artikel ini pasti ada salah satu pengguna MikroTik yang memikirkan bagaimana mengetahui keadaan jaringan yang terkelola selama jauh dari kontrol langsung, salah satu nya yaitu menggunakan Bot telegram ini, Salah fitur Mikrotik yang Amarilo pakai untuk memonitor adalah netwatch berfungsi mengecek keadaan IP dengan ping berulang-ulang dengan interval yang bisa kita atur sesuai kenginginan, tentunya kalau kita bisa memonitor secara langsung bisa kita lihat apakah keadaan IP yang kita masukkan kedalam netwatch dalam keadaan DOWN atau UP, lalu bagaimana jika kita pas tidak bisa memonitor secara langsung atau kita tidak bisa menjangkau Mikrotik ? jawabanya adalah dengan Bot Telegram yang akan Amarilo bahas dalam artikel ini. 

    Kita hanya memerlukan ponsel android yang sudah terinstal Telegram dan tentunya jaringan yang kita kelola.

Membuat BOT Telegram

Membuat Bot Dengan BotFather

    Pertama buka Telegram disitu kita disuguhi tampilan awal yang familiar dengan aplikasi pesan lain, kita akan membuat Bot terlebih dahulu dan kita harus meminta izin sang BotFather / Bapak Bot yang bisa kita cari di pencarian di menu pojok kiri atas lalu ketikkan @Botfather maka akan muncul diatas sendiri dengan centang biru dikanannya, Kita masuk ke dalam  dan mulai percakapan denganya, lalu kita masukkan pertintah untuk membuat Bot.

Perintah membuat bot

  1. “/Newbot” = untuk membuat Bot baru (tanpa tanda petik).
  2. Lalu kita akan mamasukkan nama panggilan untuk bot yang akan kita buat misal "Amarilovans".
  3. Terakhir kita masukkan lagi nama yang akan kita gunakan untuk memanggilnya dan nama tersebut harus di akhiri dengan "_bot", Seperti"Amarilovans_bot".
  4. Maka kita akan mendapat jawaban dari Botfather yang berisikan petunjuk dan token yang Amarilo tandai merah seperti pada gambar dengan format #######:################ Simpan kode tersebut karena kita akan memerlukanya.

lalu kita akan mensetting bot tersebut agar bisa masuk kedalam grup dengan perintah /mybot yang kita masukkan ketika kita chat ke Botfather seperti pada gambar.


mengatur bot


    Tahap selalnjutnya yaitu kita akan membuat sebuah grup yang kita isi dengan anggota Bot jadi ini adalah tempat dimana Bot tersebut memberikan pesan notif terkait MikroTik yang kita kelola.

Kita buat sebuah grup dengan nama yang dikehendaki misal “Monitoring MikroTik”
Lalu kita undang Bot yang dibuat tadi

Membuat Grup Telegram

Kemudian kita test di browser dengan kode script di bawah ini
https://api.telegram.org/bot#######:################/getUpdates

ganti #######:################ dengan token yang kita dapat dari BotFather
 
jika berhasil maka akan muncul  serangakaian tulisan dan kode Chat Id  daripada grup yang kita buat tadi.

test Chat ID bot
Simpan Chat ID Yang tertera Seperti pada gambar.


Monitoring Mikrotik Dengan Telegram

Terahir kita akan mensetting mikotik, dan kita akan menggunkan netwatch sebagai Tools untuk memonitor jaringan yang kita kelola.

Mengatur netwatch

  1. Klik Tools
  2. Pilih Netwatch
  3. Tambah Interface baru
  4. a. Host Kita isi sesuai dengan Ip Addres yang akan kita monitor
    b. Interval kita sesuaikan dengan lama nya netwatch mengecek ip tersebut

Script Netwatch Mikrotik Telegram

Lalu Kita akan mengisi script pada bagian UP dengan script dibawah ini :
 
:local hh $host
:local bot "XXXX:XXXXXXXXXXX"
:local chat "@@@@@@@"
:local datetime "Tanggal: $[/system clock get date] %0A Jam: $[/system clock get time]"
/tool fetch url="https://api.telegram.org/bot$bot/sendmessage\?chat_id=$chat&text=$datetime %0ARouter: $hh ON \E2\9C\85" keep-result=no
 
Lalu Pada bagian Down Kita isi Dengan Script :
 
:local hh $host
:local bot " XXXX:XXXXXXXXXXX "
:local chat "@@@@@@@"
:local datetime "Tanggal: $[/system clock get date] %0A Jam: $[/system clock get time]"
:local com [/tool netwatch get value-name=comment [find host=$hh] comment];
/tool fetch url="https://api.telegram.org/bot$bot/sendmessage\?chat_id=$chat&text=$datetime %0ARouter: $com $hh OFF \E2\9D\8C " keep-result=no

Setting Script netwatch


Catatan :
Ganti “XXXX:XXXXXXXXXXX” dengan token Bot yang kita buat.
Dan ganti “@@@@@@@” dengan Chat ID Grup yang kita peroleh tadi.
Cobalah dengan men Disable – Enable untuk mengetahui apakah berhasil atau tidak, jika berhasil akan nampak pada chat di Grup Telegram.

Hasil test monitoring dengan bot telegram


    Cara yang Amarilo sebutkan merupakan cara yang paling mudah dan sederhana yang tidak perlu adanya pengubahan pada settingan mikrotik, dan hanya sebatas mengetahui IP yang kita monitor melalui ping yang dijalankan apakah RTO atau tidak, dan tentu hal tersebut sangat membantu karena kita tidak perlu mondar mandir mengecek melalui mikrotik secara langsung, kita juga tidak selalu bisa mengontrol mikrotik dari jarak jauh entah itu perkara jaringan yang sulit atau faktor lain.

    Sebenarnya masih banyak cara yang bisa ditempuh unutuk memonitor Mikrotik salah satunya yang Amarilo bahas pada artikel ini, mungkin akan Amarilo bahas cara - cara yang lain pada waktu yang tepat nantinya, sekian artikel ini semoga bermanfaat bagi agan yang membaca dan terima kasih sudah mampir ke blog Amarilo yang sederhana ini





 





Amarilo
Amarilo Blogger Kesayangan Mama ㅇ_ㅇ

Posting Komentar untuk "Monitor Mikrotik dengan Netwatch dan Bot Telegram"